Failles de sécurité Plugins Thèmes WordPress semaine 26

WPServeur vous informe des dernières failles de sécurité plugins et thèmes WordPress connues :

Plugins WordPress

  • Custom 404 Pro <= 3.2.7 - Authenticated Reflected XSS
  • CP Contact Form with Paypal <= 1.2.97 - Authenticated XSS
  • Deny All Firewall <= 1.1.6 - CSRF
  • Seo By Rank Math <= 1.0.27 - Authenticated Settings Reset
  • Import users from CSV with meta <= 1.14.1.2 - XSS
  • Shortlinks by Pretty Links <= 2.1.9 - Stored XSS and CSV Injection
  • Sina Extension For Elementor <= 2.2.0 - LFI
  • Messenger Customer Chat <=1.2 - CSRF
  • WP Statistics <= 12.6.5 - Authenticated Stored XSS
  • WP Google Maps <= 7.11.27 - Admin Settings CSRF
  • WP-Members <= 3.2.7 CSRF Issue
  • Download Manager <= 2.9.96 - Various Sanitisation Issues
  • Easy Download Manager <= 2.9.15 - Stored XSS

Thèmes WordPress

  • Traveler - Travel Booking WordPress Theme 2.7.1 - Reflected & Stored XSS
  • JobCareer | Job Board Responsive WordPress Theme 2.5 - Stored XSS
  • CarSpot Theme <= 2.1.6 - Authenticated Stored XSS
  • ElegantThemes (divi, extra, divi-builder) - Cross-site request forgery
  • Newspaper Theme <= 9.2.2 - Cross-Site Scripting (XSS)
  • JobCareer | Job Board Responsive WordPress Theme <= 2.4 - User enumeration & Reset password
  • ElegantThemes (divi, extra, divi-builder) - Authenticated Stored Cross-Site Scripting (XSS)
  • Supreme Directory Theme <= 1.1.8 - Unauthenticated Cross-Site Scripting (XSS)

Failles WordPress

  • WordPress 3.9-5.1 - Comment Cross-Site Scripting (XSS)
  • WordPress 3.7-5.0 (except 4.9.9) - Authenticated Code Execution
  • WordPress <= 5.0 - Authenticated File Delete
  • WordPress <= 5.0 - Authenticated Post Type Bypass
  • WordPress <= 5.0 - PHP Object Injection via Meta Data
  • WordPress <= 5.0 - Authenticated Cross-Site Scripting (XSS)
  • WordPress <= 5.0 - Cross-Site Scripting (XSS) that could affect plugins
  • WordPress <= 5.0 - User Activation Screen Search Engine Indexing
  • WordPress <= 5.0 - File Upload to XSS on Apache Web Servers

Nous vous conseillons vivement de vérifier les mises à jour de ces plugins/thèmes. S'il n'y a pas de patch à jour, nous vous conseillons purement et simplement de les supprimer au plus vite de votre installation WordPress !

N'oubliez pas de mettre à jour régulièrement WordPress et ses plugins à l'aide de notre système d'auto-update.

 

Les différents types de failles de sécurité :

  • SQL injection :  faille de sécurité d’une application interagissant avec la base de données, en injectant une requête SQL non prévue par le système et pouvant compromettre sa sécurité.
  • XSS : Cross-Site Scripting, faille de sécurité permettant d’injecter du contenu dans une page, afin de provoquer des actions sur les navigateurs web visitant la page
  • CSRF : Cross-Site Request Forgery ou XSRF, est un type de vulnérabilité des services d'authentification web. L’objet de cette attaque est de transmettre à un utilisateur authentifié une requête HTTP falsifiée qui pointe sur une action interne au site.

Envie d'un WordPress mieux sécurisé ?