Failles de sécurité Plugins Thèmes WordPress semaine 36

WPServeur vous informe des dernières failles de sécurité plugins et thèmes WordPress connues :

Plugins WordPress

  • WooCommerce <= 3.4.4 - Potential Object Injection
  • Jibu Pro <= 1.7 - Authenticated Stored Cross-Site Scripting (XSS)
  • Ninja Forms <= 3.3.13 - Cross-Site Scripting (XSS) in Import Function
  • Plainview Activity Monitor <= 20161228 - Remote Command Execution (RCE)
  • Gift Voucher - Authenticated Blind SQL Injection
  • Ajax BootModal Login <= 1.4.3 - Captcha Reuse
  • Ninja Forms <= 3.3.13 - CSV Injection
  • Chained Quiz <= 1.0.8 - Unauthenticated SQL Injection

Thèmes WordPress

  • Supreme Directory Theme <= 1.1.8 - Unauthenticated Cross-Site Scripting (XSS)
  • BBE Theme <= 1.52 - Direct Object Reference
  • Swape Theme - Authentication Bypass and Stored XSS
  • Enfold Theme <= 4.2 - Rewrite Portfolio Permalink Structure & Information Disclosure
  • Pinfinity Theme <= 1.9.2 - Reflected Cross-site Scripting (XSS)
  • Bridge Theme <= 11.1 - DOM Cross-Site Scripting (XSS)
  • Salutation Responsive WordPress + BuddyPress Theme <= 3.0.15 - Stored XSS
  • Avada Theme <= 5.1.4 - Stored Cross-Site Scripting (XSS) & CSRF
  • Atahualpa Theme - Authenticated Cross-Site Scripting (XSS)

Failles WordPress

  • WordPress <= 4.9.6 - Authenticated Arbitrary File Deletion
  • WordPress 3.7-4.9.4 - Remove localhost Default
  • WordPress 3.7-4.9.4 - Use Safe Redirect for Login
  • WordPress 3.7-4.9.4 - Escape Version in Generator Tag
  • WordPress <= 4.9.4 - Application Denial of Service (DoS) (unpatched) - Protection en amont chez WPServeur
  • WordPress 3.7-4.9.1 - MediaElement Cross-Site Scripting (XSS)
  • WordPress 2.8.6-4.9 - Authenticated JavaScript File Upload
  • WordPress 1.5.0-4.9 - RSS and Atom Feed Escaping/li>
  • WordPress <= 4.8.2 - $wpdb->prepare() Weakness
  • WordPress 2.9.2-4.8.1 - Open Redirect
  • WordPress 3.0-4.8.1 - Path Traversal in Unzipping

Nous vous conseillons vivement de vérifier les mises à jour de ces plugins/thèmes. S'il n'y a pas de patch à jour, nous vous conseillons purement et simplement de les supprimer au plus vite de votre installation WordPress !

N'oubliez pas de mettre à jour régulièrement WordPress et ses plugins à l'aide de notre système d'auto-update.

 

Les différents types de failles de sécurité :

  • SQL injection :  faille de sécurité d’une application interagissant avec la base de données, en injectant une requête SQL non prévue par le système et pouvant compromettre sa sécurité.
  • XSS : Cross-Site Scripting, faille de sécurité permettant d’injecter du contenu dans une page, afin de provoquer des actions sur les navigateurs web visitant la page
  • CSRF : Cross-Site Request Forgery ou XSRF, est un type de vulnérabilité des services d'authentification web. L’objet de cette attaque est de transmettre à un utilisateur authentifié une requête HTTP falsifiée qui pointe sur une action interne au site.

Envie d'un WordPress mieux sécurisé ?